Inptools-Handbuch

Steffen Macke

<sdteffen@sdteffen.de>

Copyright © 2008, 2009, 2011, 2012, 2014 Steffen Macke

Dieses Dokument wurde unter der GNU-Lizenz für freie Dokumentation veröffentlicht.

Es ist erlaubt, das Bild zu kopieren, verbreiten und/oder zu modifizieren, unter den Bedingungen der GNU-Lizenz für freie Dokumentation, Version 1.2 oder einer späteren Version, veröffentlicht von der Free Software Foundation.

Die Free Software Foundation stellt eine Kopie der Lizenz zur Verfügung: http://www.gnu.org/licenses/fdl.html

$Date 2014-01-28$

Inhaltsverzeichnis

Allgemein
1. Einführung
1.1. Was ist Neu?
1.1.1. Version 2.0.12.1
1.1.2. Version 1.0.1
1.1.3. Version 1.0.0
1.1.4. Version 0.2.2
1.1.5. Version 0.2.0
1.1.6. Version 0.1.0
2. Voraussetzungen
3. Installation
3.1. Installation unter Windows
3.2. Installation unter Linux
Referenz
1. Benutzung
1.1. Windows Explorer Integration
1.1.1. Mit EPANET öffnen
1.1.2. Deutschen Bericht erstellen
1.1.3. Projektion von GK3 nach WGS84
1.1.4. CSV Ergebnisdateien erzeugen
1.1.5. Binäre Ergebnisdatei erzeugen
1.1.6. Shapefiles erzeugen
1.2. Kommandozeile
1.2.1. inp2shp
1.2.2. inpproj
1.2.3. epanet2l
1.2.4. epanet2csv
2. Fehlerbehandlung und Support
3. Licenz
3.1. Shapelib License
3.2. PROJ.4 License
3.3. Gettext License
Index


Allgemein

Inhaltsverzeichnis

1. Einführung
1.1. Was ist Neu?
1.1.1. Version 2.0.12.1
1.1.2. Version 1.0.1
1.1.3. Version 1.0.0
1.1.4. Version 0.2.2
1.1.5. Version 0.2.0
1.1.6. Version 0.1.0
2. Voraussetzungen
3. Installation
3.1. Installation unter Windows
3.2. Installation unter Linux


1. Einführung

1.1. Was ist Neu?
1.1.1. Version 2.0.12.1
1.1.2. Version 1.0.1
1.1.3. Version 1.0.0
1.1.4. Version 0.2.2
1.1.5. Version 0.2.0
1.1.6. Version 0.1.0

Inptools sind Werkzeuge, um Dateien im EPANET INP Format zu bearbeiten.

Inptools sind erhältlich unter epanet.de/inptools .

Dieses Handbuch beschreibt die Version 1.0.1 der Inptools.


1.1. Was ist Neu?

1.1.1. Version 2.0.12.1
1.1.2. Version 1.0.1
1.1.3. Version 1.0.0
1.1.4. Version 0.2.2
1.1.5. Version 0.2.0
1.1.6. Version 0.1.0

Ein Zusammenfassung der Änderungen.


1.1.1. Version 2.0.12.1

  • Explorer-Integration für inp2shp. Nutzen Sie das Explorer-Kontextmenü, um aus INP-Dateien Shapefiles zu erzeugen.

  • Mehrerer Fehler in der inp2shp-Anwendung wurden behoben.

  • Die ersten drei Zahlen der Versionsnummer entsprechen jetzt denen der im Windows-Installationspaket enthaltenen EPANET-Version.


1.1.2. Version 1.0.1

  • Fehlerkorrektur bei der Erzeugung von CSV-Dateien: Der Dateiname "node.csv" wurde für Leitungsdaten angeboten.


1.1.3. Version 1.0.0

  • EPANET 2.0.0.12 wurde zusammen mit der Dokumentation zum Installationsprogramm hinzugefügt.

  • Die Windows-Version erfordert mindestens Windows 7.

  • Verbesserte Windows-Explorer-Integration: Ein Doppelklick auf *.net und *.inp-Dateien öffnet diese in epanet2w.


1.1.4. Version 0.2.2

  • Das Programm inp2shp wurde ins Paket aufgenommen.


1.1.5. Version 0.2.0

  • Das Kontextmü im Windows Explorer wurde um die Funktionen "CSV Ergebnisdatei erstellen", "binäre Ergebnisdatei erstellen" und "Hilfe" erweitert.

    Das Programm epanet2csv wurde ins Paket aufgenommen.


1.1.6. Version 0.1.0

  • Die erste öffentliche Freigabe.


2. Voraussetzungen

Linux oder Windows (7, 8, 8.1 oder neuer) werden benötigt, um die Inptools-Software zu nutzen.

Inptools 0.2.3 ist die letzte Version, die ältere Windows-Versionen unterstützt.


3. Installation

3.1. Installation unter Windows
3.2. Installation unter Linux

Wie die Inptools-Software installiert wird.


3.1. Installation unter Windows

Wie die Inptools unter Windows installiert werden.

Laden Sie das Installationsprogramm von epanet.de/inptools herunter und führen Sie es aus.


3.2. Installation unter Linux

Wie die Inptools unter Linux installiert werden können.

Laden Sie das RPM-Paket von epanet.de/inptools herunter und installieren Sie es.


Referenz

Inhaltsverzeichnis

1. Benutzung
1.1. Windows Explorer Integration
1.1.1. Mit EPANET öffnen
1.1.2. Deutschen Bericht erstellen
1.1.3. Projektion von GK3 nach WGS84
1.1.4. CSV Ergebnisdateien erzeugen
1.1.5. Binäre Ergebnisdatei erzeugen
1.1.6. Shapefiles erzeugen
1.2. Kommandozeile
1.2.1. inp2shp
1.2.2. inpproj
1.2.3. epanet2l
1.2.4. epanet2csv
2. Fehlerbehandlung und Support
3. Licenz
3.1. Shapelib License
3.2. PROJ.4 License
3.3. Gettext License


1. Benutzung

1.1. Windows Explorer Integration
1.1.1. Mit EPANET öffnen
1.1.2. Deutschen Bericht erstellen
1.1.3. Projektion von GK3 nach WGS84
1.1.4. CSV Ergebnisdateien erzeugen
1.1.5. Binäre Ergebnisdatei erzeugen
1.1.6. Shapefiles erzeugen
1.2. Kommandozeile
1.2.1. inp2shp
1.2.2. inpproj
1.2.3. epanet2l
1.2.4. epanet2csv

Inptools können über ein Kontextmenü im Windows Explorer oder über die Kommandozeile genutzt werden.


1.1. Windows Explorer Integration

1.1.1. Mit EPANET öffnen
1.1.2. Deutschen Bericht erstellen
1.1.3. Projektion von GK3 nach WGS84
1.1.4. CSV Ergebnisdateien erzeugen
1.1.5. Binäre Ergebnisdatei erzeugen
1.1.6. Shapefiles erzeugen

Windows Explorer Integration

Öffnen Sie den Windows Explorer.

Navigieren Sie zu einer Datei im INP-Format.

Klicken Sie mit der rechten Maustaste auf die INP-Datei.

Wählen Sie das Inptools-Menü.


1.1.1. Mit EPANET öffnen

Wählen Sie Inptools->Mit EPANET öffnen, um die gewählte INP-Datei in epanet2w interaktiv zu bearbeiten.

Diese Option steht nur zur Verfügung, wenn EPANET installiert ist.


1.1.2. Deutschen Bericht erstellen

Wählen Sie Inptools->deutschen Bericht erstellen, um aus der gewählten INP-Datei einen Berechnungsbericht in deutscher Sprache zu erstellen.


1.1.3. Projektion von GK3 nach WGS84

Wählen Sie Inptools->Projektion von GK3 nach WGS84, um die gewählte INP-Datei mit mit Gauß-Krüger Koordinaten (GK3) in eine neue INP-Datei mit geographischen (WGS84) Koordinaten zu konvertieren (projezieren).


1.1.4. CSV Ergebnisdateien erzeugen

Wählen Sie Inptools->CSV Ergebnisdateien erzeugen, um aus der gewählten INP-Datei zwei CSV-Dateien mit den Berechnungsergebnissen zu erzeugen. Eine Datei wird Knotenergebnisse enthalten, die andere Leitungsergebnisse.


1.1.5. Binäre Ergebnisdatei erzeugen

Wählen Sie Inptools->binäre Ergebnisdatei erzeugen, um aus der gewählten INP-Datei einen Berechnungsbericht und eine binäre Ergebnisdatei zu erzeugen. Die binäre Ergebnisdatei kann beispielsweise mit dem Kommandozeilenwerkzeug epanet2csv weiterverarbeitet werden.


1.1.6. Shapefiles erzeugen

Wählen Sie Inptools->Shapefiles erzeugen, um aus der gewählten INP-Datei mehrere Shapefiles (Knoten, Leitungen, Pumpen, Tanks, Reservoirs) zu erzeugen.

Die erzeugten Shapefiles können mit entsprechender GIS-Software (wie beispielsweise QGIS) geöffnet werden. Falls Sie QGIS nutzen, könnte Sie das Plugin "GHydraulics" interessieren.


1.2. Kommandozeile

1.2.1. inp2shp
1.2.2. inpproj
1.2.3. epanet2l
1.2.4. epanet2csv

Das Inptools-Paket enthält mehrere Kommandozeilenwerkzeuge.

[Anmerkung] Anmerkung

Die Nutzung der Kommandozeilenwerkzeuge ist optional für Windows-Nutzer. Falls ihnen die Kommandozeile unbekannt ist, sollten sie statt dessen das Kontextmenü des Windows Explorers ( Abschnitt 1.1, „Windows Explorer Integration“ ).


1.2.1. inp2shp

Der Befehl inp2shp konvertiert eine INP-Datei in einen Satz von Shapefiles.

1.2.1.1. Übersicht
                      inp2shp inpfile reportfile junction_shapefile pipe_shapefile pump_shapefile reservoir_shapefile tank_shapefile valve_shapefile


1.2.2. inpproj

Der Befehl inpproj konvertiert (projeziert) eine INP-Datei mit Gauß-Krüger Koordinaten (GK3) in eine neue INP-Datei mit geographischen (WGS84) Koordinaten.

1.2.2.1. Übersicht
          inpproj inputfile outputfile


1.2.3. epanet2l

epanet2l ist eine modifizierte (lokalisierte) Version von epanet2d, die es erlaubt, Berichte in deutscher Sprache zu erzeugen.

Die LANG-Umgebungsvariable zur Konfiguration der epanet2l-Sprache genutzt werden.

1.2.3.1. Übersicht
epanet2l inpdatei berichtsdatei [binäre_ergebnisdatei]


1.2.4. epanet2csv

epanet2csv konvertiert eine binäre EPANET-Ergebnisdatei in zwei CSV-Dateien. CSV-Dateien können von Tabellenkalkulationssoftware wie OpenOffice Calc oder Excel, relationalen Datenbanken wie PostgreSQL oder MySQL und GIS-Software gelesen werden.

1.2.4.1. Übersicht
epanet2csv binäre_ergebnisdatei knoten.csv leitungen.csv


2. Fehlerbehandlung und Support

Bitte berichten Sie alle Probleme über das Support-Formular auf epanet.de:

http://epanet.de/en/support.php


3. Licenz

3.1. Shapelib License
3.2. PROJ.4 License
3.3. Gettext License

Inptools Tools to work with EPANET INP files.

Copyright (C) 2001, 2008, 2009, 2011 Steffen Macke

This program is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the Free Software Foundation; either version 3 of the License, or (at your option) any later version.

This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details.

You should have received a copy of the GNU General Public License along with this program; if not, see http://www.gnu.org/licenses/.


3.1. Shapelib License

The inp2shp and shp2inp commands use shapelib under the terms of the LGPL.

Copyright (c) 1999, Frank Warmerdam

This software is available under the following "MIT Style" license, or at the option of the licensee under the LGPL (see LICENSE.LGPL). This option is discussed in more detail in shapelib.html

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.


3.2. PROJ.4 License

The inpproj command use the PROJ.4 cartographic projections library.

Copyright (c) 2000, Frank Warmerdam

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.


3.3. Gettext License

Several Inptools commands use gettext under the terms of the LGPL.

Copyright (c) 1991 Free Software Foundation

This software is available under the following "MIT Style" license, or at the option of the licensee under the LGPL (see LICENSE.LGPL). This option is discussed in more detail in shapelib.html

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.